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IAR Embedded Workbench for ModusToolbox™
user guide

ModusToolbox™ tools package version 3.1.0

About this document

Scope and purpose

ModusToolbox™ software is a set of tools and libraries that support device configuration and application
development. These tools enable you to integrate our devices into your existing development methodology.
This document provides information and instructions for using IAR Embedded Workbench with
ModusToolbox™ software.

Document conventions

Convention Explanation

Bold Emphasizes heading levels, column headings, menus and sub-menus.

Italics Denotes file names and paths.

Courier New Denotes APIs, functions, interrupt handlers, events, data types, error handlers, file/folder names,
directories, command line inputs, code snippets.

File > New Indicates that a cascading sub-menu opens when you select a menu item.

Reference documents

Refer to the following documents for more information as needed:

e ModusToolbox™ tools package installation guide -Provides information and instructions about installing
the tools package on Windows, Linux, and macOS.

e ModusToolbox™ tools package user guide -Provides information about all the tools included with
ModusToolbox™ tools package.

e Project Creator user guide -Provides specific information about the Project Creator tool.
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Download/install software

1 Download/install software

1.1 ModusToolbox™ tools package

Refer to the instructions in the ModusToolbox™ tools package installation guide for how to download and
install the ModusToolbox™ tools package.

1.2 IAR Embedded Workbench (Windows only)

IAR Embedded Workbench version 8.42.2 or later. Recommended version 9.32.1.

1.3 Python

Python 3.8 is installed in the tools_3.x directory, and the make build system has been configured to use it. You
don't need to do anything if you use the modus-shell/Cygwin.bat file to run command line tools.

However, if you plan to use your own version of Cygwin or some other type of bash, you will need to ensure
your system is configured correctly to use Python 3.8. Use the CY PYTHON PATH as appropriate.

1.4 J-Link

For J-Link debugging, download and install J-Link software:

https://www.segger.com/downloads/J-Link/J-Link Windows.exe

User guide 3 002-37598 Rev. *A
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Getting started

2 Getting started

This section covers the ways to get started using IAR Embedded Workbench with ModusToolbox™ software.

e Create new application

e Exporting existing application

e Open application in IAR Embedded Workbench
e Build the application

2.1 Create new application

Creating an application includes several steps, as follows:

2.1.1 Step 1: Open Project Creator tool

The ModusToolbox™ Project Creator tool is used to create applications based on code examples and template
applications. By default, the tool is installed in the following directory:

<user_home=>/ModusToolbox/tools_<version>/project-creator

The tool is provided in GUI form and as a command line interface. For more details, refer to the Project Creator
user guide.
You can open the tool from the Windows Start menu, or by launching the executable in the installation

directory.

Note: You can also launch the Project Creator tool from the ModusToolbox™ Dashboard. Refer to the
Dashboard user guide for more details.

User guide 4 002-37598 Rev. *A
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2.1.2

When the Project Creator tool opens, expand one of the BSP categories under Kit Name and select an

Step 2: Choose Board Support Package (BSP)

appropriate kit; see the description for it on the right. For this example, select the CYS8CKIT-06252-43012 kit.
The following image is an example; the precise list of boards available in this version will reflect the platforms
available for development.

[ Choose Board Support Package (BSP) - Project Creator 2.10 - O >
Settings  Help
Source Template
|EntE|‘ filter text... /7 || Create from MPM...| Browse for BSP.. |5 CYSCKIT-06252-43012 -
Kit Mame MCU/SOC/SIP Connectivity | | The CYBCKIT-06252-43012 PSolC™
PMG BSPs ESEEEi—FC: BTPiorifer Kiti;alow—
PSoC™ 4 BSPs cost har ware pla orm that
v PSoC™ f BSPs enables design and debug of
PSoC™ & MCUs. It comes with a
CYBCEVAL-DB252 CY8CE24ABZI-52D44 “None> Murata 1LY Module (Cw4301 2
CYBCEVAL-06252-LAI-43435M2  CYBCE24AB71-52D44 Sterling-LWB+ (CYW43439KUBG) Wi-Fi + Bluetooth Combo Chip),
CYBCEVAL-06252-LAI-4373M2 CYBCE24ABZI-52044 Sterling-LWE3+ (CYW4373EUBGT) industry-leading CAPSEMSE™ for
CYBCEVAL-06252-MUR-43433M2  CYBCE24ABZ1-52044 LBEESKLTYM (CYW43439KUBG) touch buttons and slider, on-
CYBCEVAL-06252-MUR-4373EM2  CYBCE24ABZ1-52044 LBEESPK2AE (CYWA4373EUBGT) b?afd _debugger_a'_programmer
CYBCKIT-062-BLE CVBCEI47BZI-BLDS2  <none> wth Kitbrog n':an;chD o o
CYBCKIT-06252-42012 CY8C624ABZI-52D44 LBEESSE1LY (CYW43012C0WKWEG) INterace ua
flash, PDM-PCM microphone
CYBCKIT-0e254 CYBCE244L00-54D92 <nones interface.
CYBCKIT-062-WIFI-BT CYBCA247BZ1-054 LBEESKL1DX [CYW4343WKUBG)
CYBCKIT-064B052-4343W CYBOB4ABT|-S52044 CYWA343WKUBG Kit Features:
CYBCKIT-0645052-4343W CYS0e44AB71-52044 CYWA34IWKUBG . . B
e - * Support of up to
CYBCPROTO-062-4343W CYBCE24ABZI-52044 LBEESKL1DX [CYW4343WKUBG
¢ ) N Flash and 1MB SRAM bt
F
~
BSP: CYBCKIT-06252-43012
Press "Next" to select application, W
MNext = Cloze
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2.1.3 Step 3: Select application

Click Next > to open the Select Application page.

E Select Application - Project Creator 2,10
Settings  Help

Application(s) Root Path: | C:/Users/Test/mtw3.1/iar

Browse...

Target IDE: <None>

Enter filter text... /7 ||Browse for Application... 7 = I =

Template Application Mew Application Mame  MNew BSP Mame
Bluetooth®
Community Code Examples
Connectivity
Getting Started
Graphics
Machine Learning
Manufacturing
Peripherals
Sensing
Yoice
Wi-Fi

Select one or more template applications to proceed with the new project creation process.

< Back

Create

Cloze

This page displays example applications, which demonstrate different features available on the selected BSP.
In this case, the CY8CKIT-06252-43012 provides the PSoC™ 62 MCU and the AIROC™ CYW43012 Wi-Fi &
Bluetooth® combo chip. You can create examples for PSoC™ 6 MCU resources such as CAPSENSE™ and QSPI, as

well as numerous examples for other capabilities.

Click Browse... next to Application(s) Root Path to create or specify a folder where the application will be

created.

Pull down the Target IDE menu, and select IAR Embedded Workbench.

Application(s) Root Path:

CifUsers/Test/mtw3.1/iar

Template Application [ |1AR. Embedded Workbench

ARM MDK {uVision)

Target IDE: <Mone> ~
<Mone>

Enter filter text... Ec.I|p5e IDEfDr ModuslToolbox"
Microsoft Visual Studic Code

Browse...

Bluetooth ® TT
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Under the Template Application column, expand Getting Started and select Hello World from the list. This
example exercise uses the PSoC™ 6 MCU to blink an LED.

Template Application Mew Application Marme Mew BSP Name

¥ Getting Started

] Dual-CPU Empty P5oC6 App
L] Empty App
Hello World [BEEREEE | APP_CYBCKIT-06252-43012
[ Security App
[ Switching Power Modes

Graphics

Machine Learning

Manufacturing

Peripherals

Sensing

Voice

Wi-Fi

Note: The actual application names available might vary.

Type a name for your application and/or BSP, or leave the default names. Do not use spaces. Also, do not use
common illegal characters, such as:

*."m Y /SN T sy =y

2.1.4 Step 4: Create application

Click Create to start creating the application. The tool displays various messages.

[ Select Application - Project Creator 2.10 - O X

Settings  Help

Application(s) Root Path: | C:/Users/Test/miws3. 1 fiar Browse...
Target IDE: IAR Embedded Workbench

Enter filter text... Browse for Application.. F %= O 5 &

Template Application New Application Name = New BSP Mame

~ Getting Started

Dual-CPU Empty PSoC6 App
Empty App
Hello World Hello_World APP_CYBCKIT-06252-43012
Security App
Switching Power Modes

Graphics

Machine Learning

Manufacturing

Peripherals

Sensing

Voice

Wi-Fi

Starting application creation for 'C:/Users/Test/mtw3.1/iar/Hello_World'. 2
Acquiring the application source https://github.com/Infineon/mtb-example-hal-helle-werld'.

Acquired application source successfully.

Loading the application. v

< Back Create Close

When the process completes, a message states that the application was created. Click Close to exit the Project
Creator tool.

0 error(s), 0 warning(s) ~
Summary:
Successfully created and exported "Hello_World" application. v
< Back Create Close
User guide 7 002-37598 Rev. *A
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If you have a ModusToolbox™ application that was created for another IDE or for the command line, you can
export that application to be used in IAR. Open a terminal window in the application directory, and run the
command make ewarm TOOLCHAIN=IAR.

Getting started

2.2 Export existing application

Note: For applications that were created using core-make-3.0 or older, you must use the make ewarm8

command instead.

Note: This sets the TOOLCHAIN to IAR in the Embedded Workbench configuration files but not in the

ModusToolbox™ application’s Makefile. Therefore, builds inside IAR Embedded Workbench will use
the IAR toolchain while builds from the ModusToolbox™ environment will continue to use the
toolchain that was previously specified in the Makefile. You can edit the Makefile’s TOOLCHAIN
variable if you also want ModusToolbox™ builds to use the IAR toolchain.

Note: Check the output log for instructions and information about various flags.

2.3 Open application in IAR Embedded Workbench

An IAR connection file appears in the application directory. For example:
mtb-example-psoc6-capsense-buttons-slider-freertos.ipcf

1. StartIAR Embedded Workbench.

2. Onthe main menu, select Project > Create New Project > Empty project and click OK.

3. Browse to the ModusToolbox™ application directory, enter a desired application name, and click Save.

(<]

&« v 1t
Organize ~
J 3D Objects
[ Desktop
=/ Documents
4 Downloads
D Music
=] Pictures

Videos
5 Windows (C:)

File name:

4 Hide Folders

<« Users » vmed »

Mew folder

v

CapSenseButtonsandSliderFreeRTOS

4]

Search CapSenseButtonsands.. @

Type
File folder
File folder
File folder

File folder

Size

mth-example-psoc-capsense-buttons-slider-freertos

Save as type: | Project Files (*.ewp)

Save

Cancel

4. Afterthe application is created, select File > Save Workspace. Then, enter a desired workspace name.

5. Select Project > Add Project Connection and click OK.

User guide
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6. Onthe Select IAR Project Connection File dialog, select the .ipcffile and click Open:

< Select |AR Project Connection File

v O Search CapSenseButtonsandS... @

= @ @
Date modified Type

File folder
File folder
File folder
File folder
File folder
IPCF File

>

« - 4 > Volodymyr Medvid » CapSenseButtonsandSliderFreeRTOS
Organize v New folder
I This PC Hame
J 3D Objects -git
I Desktop build
%] Decuments imeges
libs
J Downloads
settings
D Music ;
] mtb-example-psact-capsense-buttons-slider-freertos.ipcf
=] Pictures
B Videos
25 Windows (C:)
¥ Network i
File name: | mtb-example-psock-capsense-buttens-slider-freertos.ipef

| [1AR Project Connection File (<

2.4

Build the application

Infineon

For applications using the PSoC™ 64 secure MCU, skip this step. Instead, perform the steps outlined in the
following section.

On the IAR main menu, select Project > Make.

Note:

User guide

Ifyou don't care about staying connected to the ModusToolbox™ tools that generate the project
files, you can delete the .ipcf file from the workspace and restart IAR. The official IAR site discusses

this option: https://github.com/IARSystems/project-migration-tools

If you don't remove the .ipcf file, you need to make all file/group additions at the workspace level.

e Test-IAR-2 - IAR Embedded Workbench IDE - Arm 9.10.2
File Edit View Project Simulator Tools Window Help
DOE@® = SB[ D¢
Warkspace -~ ax
Debug e
Files &
i Options...
=L
i Make
Compile
Rebuild All
Clean
C-STAT Static Analysis >
Stop Build
Testla Add > Add Files...
o e Add Group...

002-37598 Rev. *A
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2.5 PSoC™ 64 application configuration

Before building an application for a PSoC™ 64 secure MCU in IAR, you must perform the following configuration
steps.

1. Select Project > Options > Linker > Output and change file extension from ".out" to ".elf" in Output
filename field:

Opticns for node "CYBCPROTO-06451-5B_Secure_Blinky_LED_FreeRTOS_UG" *

Category Factory Setings
General Options
Static Analysis
Runtime Checking
CC++ Compiler #define  Diagnostics  Checksum  Encedings dza Cigfions
Assembler Corfig Lbrary Input  Optimizations Advancedst
Output Converter
Custom Build Output filename:
Build Actions [CYECPROTO-06457-5B_Secure_Binky_LED_FreeRTOS_UG A
Linker
Debugger Include debug information in output
Simuiator
caD!
CMSLS DAP CYBCPROTO-06451-58 _Secure_Blinky LED_FreeRTOS UG impot lib.
GDB Server
Tdet
Hink/1Trace
L Stellaris
Nu-Link
PE micro
STLING
Third-Party Driver
TLMSP-FET
TIXDS
Cancel

2. Click OKto close the dialog.
3. Build the application using the ModusToolbox™ make buildcommand.

You can do this by using a Terminal or by exporting the application to Eclipse or VS Code.
4. Copy the post-build command from the log. For example:

C:/Infineon/Tools/ModusToolbox/tools 3.1/python/python.exe C:/UG/CY8CPROTO-06451~

SB_Secure Blinky LED FreeRTOS_UG/bsps/TARGET APP CY8CPROTO-064S1-SB/psoc64 postbuild.py --
core CM4 --secure-boot-stage single --policy policy single CMO CM4 --target cyb06xx7 --
toolchain-path C:/Infineon/Tools/ModusToolbox/tools 3.1/gcc --toolchain GCC_ARM --build-dir
C:/UG/CY8CPROTO-064S1-SB Secure Blinky LED FreeRTOS UG/build/APP CY8CPROTO-064S1-SB/Debug -
—app-name mtb-example-psoc6-secure-blinkyled-freertos --cmO-app-path

../mtb_shared/catlcmOp/release-v1.0.0/COMPONENT CAT1A/COMPONENT CMOP_SECURE --cmO-app-name
psoc6 01 cmOp secure

5. Paste the command into an appropriate editor, and make the following edits:

e Add path to the policy file e.g.: ~-policy-path ../policy
e Change --build-dir parameter to Exe

e Change --app-name to you project in IAR name

Example of command after edit:

C:/Infineon/Tools/ModusToolbox/tools 3.1/python/python.exe C:/UG/CY8CPROTO-064S51-

SB_Secure Blinky LED FreeRTOS UG/bsps/TARGET APP CY8CPROTO-064S1-SB/psoc64 postbuild.py --
core CM4 --secure-boot-stage single --policy-path ../policy --policy policy single CMO CM4
--target cyb06xx7 --toolchain-path C:/Infineon/Tools/ModusToolbox/tools 3.1/gcc --toolchain
GCC_ARM --build-dir Exe --app-name CYB8CPROTO-064S1-SB_Secure_ Blinky LED FreeRTOS UG --cm0O-

app-path ../mtb_shared/catlcmOp/release—vl.0.0/COMPONENT_CATlA/COMPENENT_CMOP_SECURE --cm0-
app-name psoc6 01 cmOp secure

6. Copy the edited command.
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7. InlAR, select Project > Options > Build Actions and paste the edited command in the Post-build

command line field:

Options for nede "CYBCPROTO-06451-5B_Secure_Blinky_LED_FreeRTOS_UG" x

Category:

General Options
Static Analysis
Runtime Checking
C/C++ Compiler
Assembler
Qutput Converter
Custom Build
Linker
Debugger
Simulator
CADI
CMSIS DAP
GDE Server
T4et
IHink/3-Trace
TI Stellaris
Nu-Link
PE micro
ST-LINK
Third-Party Driver
TI MSP-FET
TIXD5

Build Actions Configuration

Pre-build command line

Post-build command line:

Cancel

8. Click OKto close the dialog.

9. OnthelAR main menu, select Project > Make to build the application.

10. Select Project > Download > Download file... and select the <project_name=>.hex file in <project_root

>\Debug\Exe.
QO open *
« v 4 [l ThisPC » Windows(C) » UG > CYBCPROTD-DG451-SB Secure Blinky LED FreeRTOS UG > Debug > Exe v O Search Bxe
Organize *  New folder - O @
A Name Date madified ]
3 Quick access
[ CYBCPROTO-DEAS1-5B_Secure_Blinky | ED_FreeRTOS_UG.elf 1
Desktop
[ CYBCPROTO-D6451-5B_Secure Blinky |ED FreeRTOS UG.hex HI
¥ Downlcads [ ] CY2CPROTO-06451-5B_Secure_Blinky_LED_FreeRTOS_UG_unsigned.hex HI
(| Documents [ CY¥BCPROTO-06451-5B_Secure_Blinky_LED_FreeRTOS_UG_upgrade.hex HI
&= Pictures | | em_eeprom.hex Hi
b avto
CYBCPROTO-D6451-58_Secure_Blin
temp
test_report No preview available,
& My Desktop
& My Documents
& My Sync

@ OneDrive - Personal

& This PC
) 3D Objects
Desktop ol
CYSCPROTO-06451-5SB_Secure_Blinky LED... Date modified: 4/10/2023 3:33 PM Date created:  4/10/2023 3:13 PM
HEX File Size: 207 KB

File name: | CYBCPROTO-06451-SB_Secure_Blinky_LED_FreeRTOS_UG.hex

| Al Files ) v

Cancel

11. Select Project >Debug without Downloading.
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3 Programming/Debugging

Connect the development kit to the host PC.

3.1 XMC7000 and TRAVEO™ Il specific steps

Because the XMC7000 and TRAVEO™ Il devices have multiple cores - even if they are not used in a single-core

application - you must perform special steps to modify the linker script for the IAR project. See
XMC7000/TRAVEQO™ Il specific steps for more details.

3.2 To use KitProg3/MiniProg4

1. Asneeded, run the fw-loader tool to make sure the board firmware is upgraded to KitProg3. See the

KitProg3 User Guide for details. The tool is in the following directory by default:

<user_home>/ModusToolbox/tools_3.1/fw-loader/bin/

2. Select Project > Options > Debugger and select CMSIS-DAP in the Driver list:

Options for node "mtb-example-psoch-capsense-buttons-slider-freertos”

Category:

Factory Settings
General Options

Static Analysis
Runtime Checking

CJC++ Compiler Setup  Download Images Multicore Exira Options  Plugins
Assembler
Output Converter Driver [F1Bunto
Custom Buid CMSIS DAP v main
Build Actions -
) Simulatar
Linker CADI
Simulator GDB Server
et
CADI
J-Link /- Trace
CMSIS DAP Tl Stelaris
GDB Server Nu-Link
Idet PE micra
ST-LINK
IHink/-Tr
o ;t‘;l e Third-Party Diver
are TI MSP-FET
Mu-Link T XDS S\debugger\Cypress\PSoCE\CYACH
PE micro
STINK
Third-Party Driver
TIMSP-FET
TIXDS

Cancel

3. Select the CMSIS-DAP node, switch the interface from JTAG to SWD, and set the Interface speed to 2MHZ.

Category: Factory Settings

General Options
Static Analysis
Runtime Checking
C/C++ Compiler Setup Interface  Breakpoints
Assembler Probe config Probe configuration fie
Output Converter .
Custom Buid
Build Actions From file
Linker Expicit
Debugger
Simulator Interface Explicit probe configuration
CADI ITAG Multi-t "

GDB Server e W0

® Auto onide defauk

Tjet Target with muitiple CP
J-Link/)-Trace

T1 Stelflaris
Nu-Link

PE micro
ST-LINK
Third-Party Driver
TI MSP-FET
TIXDS

Interface speed
2MHz

0K Cancel

4. Click OK.
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5. Select Project > Download and Debug.

The IAR Embededed Workbench starts a debugging session and jumps to the main function.

o
File Edit View Project Debug Disassembly CMSIS-DAP Tools Window Help
NOED = XK 2C S< QO EECHORNN DB CO NP » @ a-Diemsn i ml
Workspace * B X | AR Information Centerfor Arm  main.c X = | Registers 1 ~ & X Disassembly > ax
Debug ~ | |main) fol Find ] Grous|CurentCRL | Boto Mermory
Files o . :; \ seask sizes oF [ Name Value Disassembly A
E @ mtb-example-psocé-capse... ¥ €9  #define TASK CAPSENSE STACK SIZE) RO 0=00000000 0x1000'dode: Oxesb8 0x0a40
s tb-example-psoct-capsen 70 #define TASK LED STACK SIZE _SIZE) R1 0=E000ED8S 0x1000'dee2: 0xa806
{1 i capsense 7 R2 0x0£000000 0x1000'deed : OxfPEE Oxfecd
72 lengths of message R3 0x00600305 break:
73 #define SINGLE_ELEMENT_QUEUE R4 0x00000000 0x1000'dcef: Oxe?dl
i RS 0200000000 break:
75 RG 0=00000000 0x1000"deea: Oxs?d0
76 ] /AR AR AR EAREAR A4 EA KA KRR AR AR A4 EAd KA KRR AR RAR A4 RAARRAREA AR B7 i AN e (-ENA° G000
L T tion Name: main() RS 0=FC12CC38 0x1000'def0: 0x000d' 0007
T T P P P = e L D00 datd . DATDOE" 424D
Lg N R10 0x1000D55C 0x1000'def . DxDE00' Edec
80 . This fum lon sets up user tasks and then starts " "
= - R11 0=1000D55C __asn( Bkpt  1%);
82 | 4 R12 000000000 CY_HALT
K oycfy_capsense.c 83 | * Return: APSR 0x60000000 0=1000'defe: Oxbell
cycfy_clacks.c 8a | + int IPSR 000000000
B cyct_peripherals.c es | EPSR 0x01000000 0%1000 defe: 0x4770
|8 B cyciy_pins.c 86 L A A AR kAR AR AR A AR A A4 Rk A EA KRR EAR R4 KK R AR A R AR AR EAR R R KK EARAEARARRE PC int main(void)
) cycty_nspi_memslatc & 27  int main(void) SP 0=080FFB00 1
) cycty_routing.c 88 [ { IR 0x1000DE7B nain
[ cycl_system.c 89 Gy_ralt_t result; PRINASK 0x00000001
&) startup_psock_02_c. 50 BASEPRI 0x00000000 result = cybsp_init():
systemn_psach_cmd.c 2% ‘I ‘ BASEPRI_MAX 0xz00000000 0x1000'dd02: Oxf?fe Oxfbdf
& [ capsense_task.c 52 result FAULTHASK 0x00000000 if (result |= CY_RSLT_SU
F— Bl capsense_task.h 93 CONTROL 0=00000004 0x1000'dd06: 0x2800
|— Bl FresRTOSConfigh sa /* Board init failed. Stop progr CYCLECOUNTER 25153 0x1000'dd08 . 0xd001
L@ [ led_taskc 95 if (result CY_RSLT_SUCCESS) CCTIKERL 25188 CY_ASSERT(0};
led_taskh B { CCTINER2 25188 0x1000'dd0a: OxfPEf OxfEE7
- B CY_RSSERT(0) ;
main.c o | ) = CCSTEP 25188 __enable irg();
— Dmtb-example-psoch-capsen. o5 0x1000'dde: Oxb662
i Output e R led_comnand data_g = =0
101 __enable irg():
o2 0x1000°dd10: 0x2200
1035 = 0x1000'dd12: 0x2108
m[E ' e 0%1000°dd14: 0x2001
105 - 0x1000°dd16: O0xE7£7 Oxf£74 v
b- ple-p: P b fick < > v« > >
Debug Log v @ X Call Stack v ax
Lo % nain
Thu Feb 13 202013:36:38: Target reset [_call_main + 0xd]
Thu Feb 13, 2020 13:36:38: DMAC/ Trace: Configuring platiom side SWO companent
Thu Feh 13, 2020 13:36:36: INFO: Goriguring trace using 'swol 0-0xE008_EN02 _0002) seting
Thu Feb 13, 2020 13:36:36: INFO: SWO trace mode is not supported by the probe (use HeyHet Trace prabe) - trace is disak
v
< >
Build  Debuglog < 3>
Ready Ln 87, Col 15 UTF-8 CAP| NUM OVR B=

3.3

For a single-core PSoC™ 6 MCU, you must specify a special type of reset, as follows:

Category:

General Options.
Static Analysis
Runtime Checking
C/C++ Compiler
Assembler
Output Converter
Custom Buid
Build Actions
Unker
Debugger
Simulator
CADI

CMSIS DAP

Setup Interface Breakpoints

Reset

Hardware

Duraton 300 ms

J-Link/)-Trace

T1 Stellaris
Nu-Unk

PE micro
ST-LUINK
Third-Party Driver

Log commanication

Factory Settings
Delay after 500 ms
Emulator
[ Always prompt for probe
selection
Serial no
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3.4

You can use a J-Link debugger probe to debug the application.

1. Openthe Options dialog and select the Debugger item under Category.

2. Then select

To use J-Link

J-Link/J-Trace as the active driver:

Options for node "mtb-example-psoch-capsense-buttons-slider-freertos”

Category: Factary Settings
General Options
Static Analysis
Runtime Checking
CJC++ Compiler Setup  Download Images Multicore  Extra Options  Plugins
Assembler
Cutput Converter Driver [F1Runto
Custom Buid JHink/J-Trace ~ main
B.uwld Actions Simulator
Linker CADI
SIS AP
Simulator GDB Server
caD1 b
CMSLS Dap Ti Stelaris
GDE Server Nu-Link
Ljet PE micro
JLinkfTr ST-LINK
. 's”t';‘:l e Third Pty Driver
ars TI MSP-FET
Nu-Link TIXDS [G\debugger\Cypress'\PSoCE\CYSCE:
PE micro
ST-LINK
Third-Party Driver
TI MSPFET
TIXDS
Cancel

Infineon

3. Select the J-Link/J-Trace item under Category, and under the Connection tab, switch the interface to

SWD:

Options for node "mtb-ex

ample-psoch-capsense-buttons-slider-freertos”

Categon: Factory Settings
General Options
Static Analysis
Runtime Checking
CJC++ Compiler Setup  Connection  Breakpaints
Assembler Communication
Output Converter @ UsB
Custom Build
Build Actions OTICPAP:  [IP address
Linker aaa bbb.coc.ddd
Debugger
Simulator Interface JTAG scan chain
caDI OuTG JTAG scan chain with muttiple targets
CMSIS DAP ° 0
GDB Server @ED
Lt o Scan chain contains non-Am devices
TG
TI Stellaris
Nu-Link [ Log commurnication
PE micro $PROJ_DIRS cspycomm log
ST-LINK
Third-Party Driver
TIMSP-FET
TIXDS
Corca
. ™ " " i H .
Note: For PSoC™ 64 "Secure Boot" MCU, you must specify a special type of reset, as follows:

Factory Setlings

Setup  Connection  Breakpaints
Reset
Core ~
JTAG/SWD speed Clock setup
O Autg

1000 CPusosk: | |mh:

@ Fixed kHz SWO dock: [t

Adaptive kHz

4. Connecta J-Link debug probe to the 10-pin adapter (this needs to be soldered on the prototyping kits), and

start debuggi

User guide
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3.5 Program external memory

IAR EWARM has disabled external memory programming by default. The SMIF region in the *.board file must be
enabled manually for PSoC™ 6, AIROC™, and XMC7000 devices. To do that:

1. Openthe Options dialog and select the Debugger item under Category.
2. Click the Download tab and select the Override default .board file check box.

3. Identify the default .board file currently used for this project.

Options for node "iar-hello-world" x

Category: Factory Settings

General Options

Static Analysis

Runtime Chedking
C/C++ Compiler Setup Download  Images Multicore Exira Options  Plugins
Assembler

Output Converter [ Vertfy download

Custom Build [ Suppress download

Buld Actions se flash loaderds)

Linker

Qvemide default board file

Simulator |curﬂigﬁlash\oader/lrmneun/PSoCE/CYBCE:u(A.bDard
CADI -
CMSIS DAP Edt..

GDE Server
et Perform mass erase before flashing

4. Copy the default .board file from the IAR Installation directory and paste it next to the IAR project file.

5. Use atext editor to remove comment tags for the SMIF region around the <pass> element, and then
comment out the ignore element for the XIP region in the recently copied file.

Original file:
<pass> <!-—- SFLASH: Public TOCZ —->
<loader>$TOOLKIT DIRS/config/flashloader/Infineon/PSoC6/CYBC6xxA SFLASH.flash</loader>
<range>CODE 0x16007C00 0x16007FFF</range>
</pass>
KI-—— <pass> ——><|-- SMIF (XIP Reglon) —->
<1-— <1loader>$TOOLKIT DIRS/config/flashloader/Infineon/PSoC6/CYBCExxA SMIF.flash</loader> -->
<!—— <range>CODE 0x18000000 Oxl1FFFFFFF</range> ——>
<!-- </pass> —=>
<!-—— Exclude regions ——>
<ignore>CODE 0x08000000 O0x0B0FFFFF</ignore» <!-- Exclude SEAM Region -->
<ignore>CODE 0x16000000 0x160007FF</ignore>» <!-- Exclude SFLASH [SFLASH Start - User Data Start] -->
<ignore>CODE 0x16001000 0x160019FF</ignore> <!-- Exclude SFLASH [User Data End - NAR Start] -->
<ignore>CODE 0x16001C00 0x160069FF</ignore> <!-- Exclude SFLASH [NAR End - Public Key Start] —-->
<ignore>CODE 0x16006600 0x16007BFF</ignore> <!-- Exclude SFLASH [Public Key End - TOC2 Start] -->
<ignore>CODE 0x9%0300000 O0x%03FFFFF</ignore> <!-— Exclude Cy Checksum Regiocn ——>
<ignore>CODE 0x9%0500000 Ox3%05FFFFF</ignore> <!-- Exclude Cy Metadata Region —-3>
<ignore>CODE 0x9%0700000 Ox907FFFFF</ignore> <!-- Exclude eFuse Region —->
|<ignore>CODE 0x18000000 Ox1FFFFFFF</ignore> <!-- Exclude XIP Region —->
</flash board>
Edited file:
<pass> <!-— SFLASH: Public TOCZ ——>
<1loader>$TOOLKIT DIR$/config/flashloader/Infineon/PSoC6/CY8C6xxA SFLASH.flash</loader>
<range>CODE 0x16007C00 0x16007FFF</range>
</pass>
<pass><!|—— SMIF (XIP Region) ——>
<loader>8$TOOLKIT DIRS/config/flashlcoader/Infineon/PSoC6/CYBC6xxA SMIF.flash</loader:>
<range>CODE 0x18000000 Ox1FFFFFFF</range>
</pass>
<!—— Exclude regions ——>
<ignore>CODE 0x08000000 0x0B0FFFFF</ignore> <!|-- Exclude SRAM Region —->
<ignore>CODE 0x16000000 0x160007FF</ignore> <!-— Exclude SFLASH [SFLASH Start - User Data Start] —->
<ignore>CODE 0x16001000 0x160019FF</ignore> <!-- Exclude SFLASH [User Data End - NAR Start] -->
<ignore>CODE 0x16001C00 0x160059FF</ignore> <!-- Exclude SFLASH [NAR End - Public Key Start] -->
<ignore>CODE 0x16006600 0x16007BFF</ignore> <!-- Exclude SFLASH [Public EKey End - TOCZ Start] —->
<ignore>CODE 0x90300000 0x903FFFFF</ignore> <!-- Exclude Cy Checksum Region —-->
<ignore>CODE 0x90500000 0x905FFFFF</ignore> <!-- Exclude Cy Metadata Region —->
<ignore>CODE 0x90700000 0x907FFFFF</ignore> <!-- Exclude eFuse Region —-->
|<1—— <ignore>CODE 0x18000000 Ox1FFFFFFF</ignore> --> <!-- Exclude XIP Region -->
</flash_board>
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6. Save thefile.

7. InlAR, click the Browse [ ...] button, then navigate to and select the edited .board file.
Options for node "iar-hello-world" *

Category Factory Setings
General Options
Static Analysis
Runtime Checking

C/C++ Compiler Setup Download  |mages Muticors  Estra Options ~ Plugins

Assembler .

Output Converter [0 Very download

Custom Build [ Suppress download

E;\Li;&chons [ Use flash loader(s)

[l Ovenide defautt board fie

Simulator |5PROJ_D|RS CYBCExxA board

CADI

CMSIS DAP Edit

GDB Server

Lyt Perform mass erase before flashing

Iink/-Trace

I Stellaris

Mu-Link

PE micro

STLINK

Third-Party Driver

TIMSP-FET

TIXDS

e

8. Click OKwhen you are finished.

3.6 Erase PSoC™ 6 MCU with external memory enabled

To successfully erase external memory using flashloaders on PSoC™ 6 MCUs, the device's internal
flash must contain valid QSPI configuration data. It may be part of a previously programmed
application, such as the QSPI_XIP example. For more details, review section 7 of application note

AN228740.

1. Select Project > Download > Erase memory.

° Download and Debug Ctrl+D

¥ Debug without Downloading

'J Attach to Running Target

Make & Restart Debugger Ctri+=R
Restart Debugger Ctrl=5hift=R
Download ] Download active application
SFR Setup Download file...
Erase memory I
| m PR e
2. Deselect the check boxes for all regions, except 0x18000000-0x 1ffffff.

Erase Memory *
Flash loader Range ~
[ ct¥Program Files\IAR Systems\Embedded Workbench 2, 3\armconfig/fashloader/Infineon/PSoCa/CYSCExxA_, ..  0x16001a00 - 0x 1600 bff
e 'l,Program F|Ies'n,I.~'-\R Systems'l,Embedded Workbench 2. 3'nﬂrm,‘conﬁg,‘ﬂashloaderﬂnﬁneoanSoCﬁfCYSCﬁxxA 0x16005a00 - Ox 16006 5fF
B c: 'Program Files\TAR Systems'l,Embedded Workbench 9, 3'ﬁrm,’conﬁg,’ﬂashl0aderﬂnﬁneon,‘PSoCG{CYSCGx){A

v
< >
Erase all Cancel

3. Click Erase.

4. Select Project > Download > Erase memory again.
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5. Select all other regions and deselect 0x18000000-0x1fffffff.

Erase Memory *
gsh loader Range 2
:\Program Files\IAR Systems'\Embedded Workbench 2. 3\arm/config/flashloader/Infineon/PSoCE/CYECExxA_... 0x16001a00 - Ox 1600 1bff
:\Program Files\[AR Systems\Embedded Workbench 9. 3\arm/config/flashloader/Infineon/PSoCe/CYECaxxA_,.. 0x16005500 - Ox160065fF
‘\Program Files\IAR Systems\Embedded Workbench 9. 3\armconfig/flashloader/Infineon /PSoCe/CYECExxA_... 0x16007c00 - Ox 16007FfF
] ci¥Program Files\IAR Systems\Embedded Workbench 2, 3\armconfig/fiashloader/Infineon/PSoCs/CYSCExxA_, ..  0x 18000000 - x IFFFFFFF
w
£ >
Erase all Cancel

6. Click Erase.
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4 Multi-core debugging

This section describes how to set up multi-core debugging in IAR Embedded Workbench for Arm IDE (IAR). For
this purpose, we need to create an IAR workspace containing a few projects (one project per MCU core).

4.1 Supported debugger probes

e KitProg3 onboard programmer

e MiniProg4

e IARI-Jet

e J-Link

4.2 Create IAR workspace and projects

After creating a ModusToolbox™ multi-core application for use with IAR, do the following:
1. LaunchIAR.
2. Onthe main menu, select Project > Create New Project > Empty project and click OK.

3. Browse to the ModusToolbox™ project directory for one of the cores, enter a desired project name, and
click Save.

4. After the project is created, select File > Save Workspace. Then, enter a desired workspace name.
5. Select Project > Add Project Connection and click OK.

6. Onthe Select IAR Project Connection File dialog, select the .ipcf file located in the project directory for
CMO+ core and click Open.

7. Repeat steps 2-3 and 5-6 for all other core projects in the application.

Once you have a working workspace, you need to properly configure IAR projects in order to be able to
establish a multi-core debug session. Also, for some MCUs you must edit linker scripts in order to organize flash
allocation properly.

4.3 Configuring IAR projects

To launch a multi-core debug session, all projects within the workspace must be properly configured. In IAR
there is a concept of 'master' and 'slave' projects. Configure the CM0+ core project as the master project, and
configure the other cores (CM4 for PSoC™ 6 and CM7 for XMC7000) as slave projects.

4.3.1 Project configuration for CM4/CM7 (slave) core(s)

1. Select the CM4/CMT core project and go to Project > Options:
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re - AR Embedded Workbench IDE - Arm 9.30.1

Project | CMSIS-DAP  Tools Window Help

[& AddFiles...

Ca Add Group..

[41 import File List...
Add Project Connection...
Edit Configurations...
Remove

T:J Create New Project...

™ add Existing Project...

£+ Options...

Wersion Control System

B Make

Do

+
Al-F7 1t 4
it
3
i
FT |s

2. Onthedialog, select the Debugger category in the Setup tab, and then select the appropriate Driver (I-Jet,
CMSIS-DAP, J-Link):

Category:

General Options

Static Analysis

Runtime Checking
C/C++ Compiler
Assembler
Qutput Converter
Custom Build
Build Actions
Linker

Simulator

CADL

CMSIS DAP
GDB Server
Idet
Idink/3-Trace

TI Stellaris
Mu-Link

PE micro

STLINK

Factory Settings

Setup  Download Images Multicors Extra Options  Plugins

Driver F1BRunto
I ljet i I main

Setup macros
[ Use macro file(s)

Device description file
[[] Ovenide default

STOOLKIT_DIR$\CONFIG debuggertinfineon \PSoCEVCYECE | [

3. Enable hex file generation.

a. Inthe Runtime Checking > Output Converter category, select the Generate additional output check

box.

b. Ensure Output format is set to Intel Extended hex.

c. Click OK.

4. Repeat these steps for your all projects for CM4/CM7 (for triple-core MCUs)

4.3.2 XMC7000/TRAVEO™ Il specific steps

Some XMC7000 MCUs are triple-core devices. If you are going to use a second CM7 core in your IAR workspace,
you need to implicitly set the target core in project settings so that IAR understands this project is targeting a
second CM7 core. By default, IAR connects to the first CM7 core, so specifying the target core for it can be

skipped.

1. Select the project for the second CM7 core and go to Project > Options.

2. Selectthe probein the Debugger category, ans switch to the Interface tab.
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3. Select the From file radio button, click Select next to the CPU label, and choose M7_1:

Categary:

Options for node "em7_1"

X

General Options
Static Analysis
Runtime Checking
C/JC++ Compiler
Assembler
Output Converter
Custom Build
Build Actions
Linker
Debugger
Simulator
CADI
GDB Server
Ijet
Iink{1-Trace
TI Stellaris
Nu-Link
PE mico
STAINK
Third-Party Driver
TIMSP-FET
TIXDS

Factory Settings

Setup  Interface  Breakpoints
Probe corfig Probe corfiguration file
O Ao [JOvenide defaut

I @) From file I STOOLKIT_DIRS/config/debugger/Infinean./| |1
O Explicit CPU: I Select i

Inteface

Explicit probe configuration M7_0

O4TaG Muti¢arget debug system

@ SWD
Target with multiple CPUs

Interface speed
Auto detect

oK Cancel

4.

Switch to the Setup tab, and select "Custom" from the Reset pull-down menu.

Category:

General Options
Static Analysis
Runtime Checking
C/C++ Compiler
Assembler
Qutput Converter
Custom Build
Build Actions
Linker

Debugger
Simulator

CADI

GDB Server
I-jet
J-Link/J-Trace
T1 Stellaris
Nu-Link

PE micro
ST-LINK

CMSIS DAP

Setup Interface  Breakpoints

Factory Settings

Resst

Custom

Emulator

I , Always prompt for probe
selection

Serial no:

[ Log communication

$PROJ_DIRS\cspycomm.log

In addition, specify a special linker script symbol in the project settings to distinguish CM7_0 from CM7_1, since
thereis a single linker script for the two CM7 cores:

5. Select the project for the first CM7 core and go to Project > Options > Linker.

6. Add core cM7 0 =1inthe Configuration file symbol definitions field, and click OK.

Categony:

General Options
Static Analysis
Runtime Checking
CfC++ Compiler
Assembler
Qutput Converter
Custom Build
Build Actions
Linker
Debugger
Simulator
CADI
CMSIS DAP
GDEB Server
et
IHink/1-Trace

Factom Settings

Hdefine Diagnostics Checksum Encodings Extra Options

Config  Library  Input Optimizations ~ Advanced  Output  List
Linker configuration file

Owvenide default

[SPROJ_DIRS\..\bsps\TARGET_APP_KIT_xMC72_EVK\CC| | .

Edt..

Corfiguration file symbol definitions: (one per line)
_CORE_CM7_0-=1|

Do the same for the second CM7 core:

7. Select the project for the second CM7 core and go to Project > Options > Linker.

8. Add core cM7 1 =1 inthe Configuration file symbol definitions field, and click OK.
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Note: When debugging CM4/CM7 core stand-alone, make sure to rebuild the CM0+ project in case any

changes were made, since launching a debug session only loads the CMO+image, but does not
build that CMO+ project.

Build your CM4/CM7 project(s) before moving forward.

4.3.3 Project configuration for CM0+ (master) core

1. Select the CMO+ project and go to Project > Options:

@ psoct multi-core - AR Embedded Workbench IDE - Arm 9.30.1

File Edit View | Project | CMSIS-DAP Tools Window Help

Py ) @ | Le AddFiles..

Workspace Cs AddGroup.. |
n -
Debug [#] import File List...
N Add Project Connection... =
Files Edit Configurat
it Configurations... )
E @ cmlp - De io
B proj_em0) ¢ pemove
— Dpraj_cm0 b
i Outout |1 Create New Project... o
™ Add Existing Project...
£
£ Options... Alt=F7 |t 3
iat]
Version Cantrol System »
i
@ Make F s

2. Onthedialog, select the Debugger category in the Setup tab, and then select the applicable Driver (I-Jet,
CMSIS-DAP, J-Link):

Category:

Factory Settings
General Options

Static Analysis

Runtime Checking
CJ/C++ Compiler Setup  Download Images Multicore Extra Options  Plugins
Assembler
Output Converter Driver [ Bunto
Custom Build IHH - I ’mam—|
Build Actions

Linker Setup macros

Debugger [ Use macro fils(s)
Simulator
CADL
CMSIS DAP
GDE Server
faet Devige descrption file
IHink/3-Trace

11 Stellaris [ Ovenide default
Nu-Link:

$TOOLKIT_DIR$\CONFIG debugger\nfineon'P SaC

PE micro
STHINK

3. Switch to the Images tab to specify the extra image to be downloaded prior to debugging in order to
download images of all projects in one process.

a. Select the Download extra image check box.
b. Provide a Path to the CM4/CM7's HEX image.
c. Enter 0 for Offset.

Category:

Factary Settings
General Options

Static Analysis
Runtime Checking
C/C++ Compiler Setup  Download Muticore Extra Options  Plugins
Assembler P
QOutput Converter

Custom Build Path: I Userstlishchynskyimtw_psoc632\Mutt-Core-Prote | ...
Build Actions

Smulator [ Download extra image:
CADI
CMSIS DAP
GDB Server
Ijet
JLinkfITrace ] Download exra image:
TI Stellaris
Nu-Link
PE micro
STLINK

Debug info only

Debug info only
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If you provide an OUT file instead of a HEX file, the IAR IDE will fail to halt at the beginning of main () dueto
the main function present in both the CM0+ and CM4/CM7 OUT files.

Note: For triple-core MCUs you should download two extra images.

4. Add a prebuild command to build all projects prior to programming/debugging. In the Build Actions
category set Pre-build command line to:

iarbuild.exe "<cm4/cm7 proj loc>.ewp" -make Debug

Category:

General Options
Static Analysis
Runtime Checking

C/C++ Compiler Build Actions Configuration

Assembler ) )

Output Converter Pre-build command line

Custom Buid iarbuild.zxe SPROJ_DIRS\. \app_cm4\cmd4 ewp make Debug -

Build Actions Post-build command line:
Linker

ebecer |
Simulator

CADI

CMSIS DAP
GDB Server
T4et
Iink/1-Trace
T1 Stellaris
Mu-Link

If your MCU has three cores, you might want to also specify a post-build action to build project for the third
core in the same manner.

5. Enable hex file generation. In the Runtime Checking > Output Converter category:
a. Select the Generate additional output check box.

b. Ensure Output format is set to Intel Extended hex.

Categany:

Factary Settings
General Options

Static Analysis
Runtime Checking

C/C++ Compiler Output
Assembler
Generate additional output
Custom Build Output format:
Build Actions
Linker Intel Extended hex ~
DE.bugger Outpu fle
z':;aw [ Overide defaut

CMSIS DA cm0.hex
GDB Server
et
I-Link/)-Trace
T Stellaris
Nu-Link

PE micra
STLINK

6. Click OK, and then select File > Save All to save all the changes.
7. Build the project.

IAR does not provide native multi-core debugging support when using a J-Link probe. This means that in order
to launch multi-core debugging, you must open a few IAR IDE instances manually (one instance per core). Also,
multi-core debugging with a J-Link probe lacks some features available with CMSIS-DAP and I-Jet probes.
Therefore, depending on the target probe, you need to configure projects slightly differently.

4.3.4 CMSIS-DAP/I-Jet-specific configuration

1. Create a session configuration file.

This is an xml file containing a projects list that should be launched in a multi-core debug session. The

following shows an example for a triple-core device. For a dual-core device, remove the third partner node.
<?xml version="1.0" encoding="utf-8"?>
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<sessionSetup>

<partner>

<name>cm0</name>

<workspace>C:\Users\mtw-multi-core\Multicore App\multi-

core_workspace.eww</workspace>

<project>cm0</project>
<config>Debug</config>
<numberOfCores>1</numberOfCores>

<attachToRunningTarget>false</attachToRunningTarget>

</partner>

<partner>

<name>cm7_ 0</name>

<workspace>C:\Users\mtw-multi-core\Multicore App\multi-

core_workspace.eww</workspace>

<project>cm7_ 0</project>
<config>Debug</config>
<numberOfCores>1</numberOfCores>

<attachToRunningTarget>true</attachToRunningTarget>

</partner>

<partner>

<name>cm7_1</name>

<workspace>C:\Users\mtw-multi-core\Multicore App\multi-

core workspace.eww</workspace>

<project>cm7_ 1</project>
<config>Debug</config>
<numberOfCores>1</numberOfCores>

<attachToRunningTarget>true</attachToRunningTarget>

</partner>

</sessionSetup>

2. Configure multi-core debugging for the CM0+ project.

a. Goto Project > Options -> Debugger.

b. Switch to the Multicore tab.

Infineon

c. Select the Advanced radio button and specify a path to the session configuration file in the Session
configuration field.

d. Click OK.

Options for node “cm0” X
Category Factory Settings
General Options
Static Analysis
Runtime Chedking

CJ++ Compiler Setup  Download Images Multicore  Extra Options  Plugins
Assembler 3 )

Output Converter Symmetric mutticore
Custom Build Number of cores:
Build Actions
Linker Asymmetric mutticore

O Disabled

Simulator

cADI O simple

CMSIS DAP

GDE Server

Iet

Jink/3-Trace

T1 Stellaris

Nu-Link Attach partner to running target 1

PE micro (®) Advanced

ST Session configuration: |C:mtwamc7000-mulicore'sessionaml | L.}
Third-Party Driver

TIMSP-FET

TIXDS

Cancal
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3. Savethe workspace.

4.4

Launch multi-core debug session with CMSIS-DAP/I-Jet

Select the CMO project and click the Download and debug button.

Infineon

IAR builds all projects, programs all the separate images, and launches a multi-core debug session. IAR opens a
separate IDE instance for each project specified in the session file. For dual-core MCUs, it should look similar to

this:

D psock_workspace - IAR Embedded Workbench IDE - Am 9.30.1 - a X | @ psoct_workspace - Partner 1 - IAR Embedded Workbench o
Fie Eat View Piojed Debug Disssiembly CMSISDAP Tools Window He Fle Edt View Projec Debug Dissssembly CMSISDAP Tools Window Hep
ihoRe & B0 DC 2 Q2% B>ON RO EEbhomw@d & B0 DC S <G L2 0 D0 Be s Oc i Jim
maine x = | Disassembly x Disassembly
fo| o Gato:
* or one of its ffmaa ("Cypress”) ond is protected by and subject to =
rotection (un(ted states and foreign), Disassembly Disassembly
s s 0%1000' 141e: Dx00 0x0: 0x£B00 0x0BO
i 0x1000" 141e: Dx08 Oxd: Ox00el
7 agreement ac he = 0x1000'1420: Dx22 0x6: 0x0000
htotned this Softurs (WA, 0x1000' 1422: 0x05: 0xa: 0x000d
* If no EULA appli ress hereby gronts you o persondL. non-exclusive, e (E = D
'mmmf u to copy, modify, umrm-p-um F4 E U3 L ¥
e olely for use tn comection with q 0x1000° 1426 Ox60 Oxc: Oxtldef 0x800
+ Tntegrated cm it _arudhcu Ay réproduction, modiftcation, translation, SRSS_VDT_CTL |- %10 0x4%2a
* compilation, itation of this Software except ied 0x1000'1428: Dx68 0x12: 0=6B09
© chove {5 provibiced without the express wHlteen permission of Crpress. 0x1000' 142a: Dx22 0x14. 0xda2s
" Dizclatner: TS SOFTMANE IS pRVIDED A5- IS, WITH #O NARRANTY OF ANY KIND, D aie ue Dt pudnne
e e e T et et B (0 - D
« WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. Cypress = . i
* reserves the gm to make chonges to the Software Ot
* does not iLity 0%1000° 1432 Dud? Oxles: 0x2a07
Software p torc 7 0%20 Oxd121
* not authorize its products for 0x1000°1434: Dxd0 0x22: Oxdazé
‘fv\!u;f of the Cypress product int main(void) 0x24: Qxd00a
* significant pri ope! rdmw- injury
 including Cypress's product in o High Risk Product, the manufoctur 1 g:gg :ﬁ;:g
+ of such Systen or cppicotion assumes all risk of such use ond in dotng
Cypress against all Liability. aeh R .
Ox2c 0x2a07
OxZe: 0=dllS
#include "cy_pdl.h* 030 0x=003
#include "cycfg.h” e 0332 Oxda2?
. 1310001430+ Oxt0 0x34: 0x4523
* el Cs SysPn Do 0x36: 0x1883
2 0x39: 0x=0id
/* Encble global interrupts %/
enatledraty: bxtn0 Lec2: 0uat Ox3a: Oxdalf
= 0x1000'144¢8: Dxf? Oxle. OxdD0a
/* Encble CH4. CY_CORTEX M4 APPL_ADDR must be updated if CN4 memory Layout is changed. %/ 0x1000°1448: Oxe? Oxle: 0x2a00
Cy_SysEnableCw(CY_CORTEX_M3_APPL_ADDR) ; 0x1000'144a: Dxbf D40 0=d101
7% 042 0x4523
for (i) 0x1000 ' 14de: Dx10 Oxdd . 0x=017
. _esa(t kot Ox46. Oxd9le
[ Cy_SysPa_Despsleen(CY_SYSPM_WATT_FOR_INTERRUPT); o FeE peem
Ly 0x1000'1450: Oxbe Dxda O=ell4
Dxde: Oxdald
/% [] END OF FILE %/ 0x1000° 1452 Dxd? Oxede: OxdD0a
SRSS_UDT_CTL &= x50 0x2a00
1 rrla D = [
Debug Lag = 8 X |DebugLog ax
Log N Log -
Wed Sep 14,2022 145537, LawLevelResel{sotware. delsy 200) WWed Sep 142022 1455 37, Atlach o running target completed.
Wed Sep 14.2022 1455:37: LowLevelReset{script delay 200) Wed Sep 142022 1455.37: DMAC/Trace: Canfigunng plaffarm side SWID componant
Wed Sep 14,2022 1455:37: Calling reset scrpt. ResetHandler_Custom Ved Sep 142022 1455.37: MuliCore: Synchronous core execution DISABLED.
Wed Sep 14,2022 145537 Dawnload completed Wed Sep 14 2022 1455
Wed Sep 14 2022 145537 LawlsvelResersotware, deley 200) Wed Sep 14 2022 1455 37 = Silican: 1E453, Farmily 0x102, Rew.: (12 (A1)
Wed San 14 2127 145530 Tamelraset > Warl San 14 9127 1455 37 *= Flash Aot varsion 31 01320
5010 Debug log Euld | Deduglag
Ready Errors 0, Warnings 0 Ln 39, Gol 74 System CAP NUM OVR S | Ready - a5 oM ove B

The left side of the screen shows the IAR IDE instance attached to the CM0+ core. The right side shows the CM4
core not started yet. Once the Cy SysEnableCM4 ()

executing its application.

You can step through the code by switching back and forth between the two IAR IDE instances.

4.5

Launch multi-core debug session with J-Link

The IAR IDE does not have native support for the J-Link driver, which imposes some limitations:

To launch multi-core debugging with J-Link:

1.

equal to the number of cores on your MCU).

Some enhanced features like are not available; see Multi-core toolbar and CTI usage.

download all images, reset the target, and halt at the beginning of the CMO0+ project's main ().

User guide

Switch to the other IDE instances and select: Project > Attach to Running Target.

24

IAR will not automatically open separate IDE instances for each core, thus you need to do it manually.

Select the CMO+ project in the first IDE instance and click Download and Debug. The debugger will

function is executed on the CMO+ core, the CM4 will start

Open your multi-core IAR workspace in separate IDE instances (the number of IDE instances should be
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4.6 Multi-core toolbar and CTl usage (I-Jet and CMSIS-DAP only)

When multi-core debugging is established through |-Jet or CMSIS-DAP drivers, a multi-core toolbar becomes
available. It allows you to halt and resume all/single core(s) from within a single IDE instance.

Also, there is a feature called cross trigger interface (CTI). This allows you to immediately halt/resume one core
when another core is halted/resumed. For example, this might be useful if you need to check what code is
executing one of your cores when another hits a breakpoint. To use CTI, select the Run/Step/Stop affect all
cores option available for multi-core applications:

Peman | Mo - 01+ 5 e e T s L A - idh

up_psoct_02_cmOplus.s B Run/Step/Stop affect all cores

25 Run, ‘Step/Stop affect current core only
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5 Patched flashloaders for AIROC™ CYW208xx devices

To enable support for different QSPI settings, the ModusToolbox™ QSPI Configurator patches flashoader files
and stores them in the application directory. When exporting such applications to IAR EWARM, these patched
flashloader files must be copied into the appropriate directory.

1. Copy the CYW208xx_SMIF.out file located in the <app-dir>\libs\<Kit-
Name=>\COMPONENT_BSP_DESIGN_MODUS\GeneratedSource directory.

2. Paste the flashloader file to the C:\Program Files\IAR Systems\Embedded Workbench
9.0\arm\config\flashloader\Infineon\CYW208XX directory.

3. Also, to use the SEGGER J-Link debugger, paste the CYW208xx_SMIF.out file to the C:\Program
Files\SEGGER\J-Link\Devices\Cypress\catlb directory.
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